Text input in Inplace mode does not lose focus

I’m not sure if this should be a bug or a feature request, but I basically need a way to get the focus away from “editbale in prototype” text cells while in In-Place mode.

When I create prototypes in Antetype, I often work on elements in In-Place presentation mode. If I have a flyout that only appears when a mouse interaction is triggered for example, opening it in inplace mode and then pressing “D” to be able to edit elements is often easier than constantly switching the flyout from visible to collapsed in order to edit it. So I stay in In-Place Mode, make the flyout appear by clicking on the respective element and then just press D to be able to select elements in the flyout, edit them, and then I press R to go right back to testing the interactions I just created or to make other elements appear that have interactions on them. So far that’s great.

However this stops working, the moment I start typing into a cell that is set to “editable in Prototype”. While the option to enter text is great too, I do not know how to get the focus away from that text cell once I wrote something in there. I can click on any other element on the canvas that is not a text cell and press “D” but it just keeps entering Ds into that text cell.
image

Is there any way to bypass this issue that I am not aware of? Or can you just have the text input field lose focus once the user clicked anywhere outside of it, so that the keyboard shortcuts become available again instead of writing into the text field?

1 Like

:thinking: using the most simple way (a screen with a cell with “editable in prototype” set) I can click on the screen and get the focus away from the text-input. But what I think is not as expected that I still can edit the text, even in selection mode…

editable.zip (215.4 KB)

if you try it here, does It work for you (apart from the wrong edit-behaviour in “Selection Mode”)?

I added two background Cells to your file since there is usually no way to click on the actual canvas in a prototype. It weirdly only works the first time I click outside the text box after entering interaction mode, but if I click into the text field again, it keeps writing d into the text field, no matter where I click.

Textbox behaviour.mov.zip (5.5 MB)

Definitely something confusing going on here. Here another prototype with another cell, displaying the current mode:

editable+.zip (239.2 KB)

GDInplaceRunTool = “Run Mode”
GDNativeSelectionTool = “Selection Mode”

For me it breaks once I focus the text cell while in “Selection Mode”. After this it stays there. Which should not be possible (it should just behave like in normal editing the prototype). But maybe this is depends also on the WebKit (Safari)-Version. I am using 13.0.1.

I am not sure where I can see which version of Webkit Safari is using, but it should be the one that comes with the latest version of safari. I am still running Monterey Version 12.6.1. but I doubt that really makes a significant difference.

In your file , the InplaceRunTool activates once I start inplace mode (so far so good) It stays in Inplace mode when I click the text field (also good) and then changes to nativeSelectionTool once I click on another cell and press “d” on the keyboard (so far perfect).

Once I click into the text cell again however, it stays in nativeSelectionTool mode, but the cell becomes editable again. From there on, pressing d always writes into the cell, no matter where I click.

editable+.mov.zip (2.0 MB)


ok, then if we disable text-editing while in Direct Selection this should fix it? But I have to try it again step by step too, to easy to get it wrong.

Concerning the Safari-version: I never found a way to get the version used in the embedded WebView, I think the macOS-version is enough for us.